Ubuntu-.deb

Submitted by kdeturck on Fri, 04/22/2016 - 14:51
Forums

Hi!
Under Ubuntu 16.04, with the binary package freeling-3.1-quantal-x86_64.deb ; I have installed all the required libraries following the user man. When I run sudo dpkg -i freeling-3.1-quantal-x86_64.deb, I obtain the following error:
dpkg: des problèmes de dépendances empêchent la configuration de freeling :
freeling dépend de libboost-program-options1.49.0 (>= 1.49) ; cependant :
Le paquet libboost-program-options1.49.0 n'est pas installé.
freeling dépend de libboost-regex1.49.0 (>= 1.49) ; cependant :
Le paquet libboost-regex1.49.0 n'est pas installé.
freeling dépend de libboost-system1.49.0 (>= 1.49) ; cependant :
Le paquet libboost-system1.49.0 n'est pas installé.
freeling dépend de libicu48 (>= 4.8.1) ; cependant :
Le paquet libicu48 n'est pas installé.

dpkg: erreur de traitement du paquet freeling (--install) :
problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
freeling

Some dependencies problem. Many thanks!

Some precisions:
Les paquets suivants contiennent des dépendances non satisfaites :
freeling : Dépend: libboost-program-options1.49.0 (>= 1.49) mais il n'est pas installable
Dépend: libboost-regex1.49.0 (>= 1.49) mais il n'est pas installable
Dépend: libboost-system1.49.0 (>= 1.49) mais il n'est pas installable
Dépend: libicu48 (>= 4.8.1) mais il n'est pas installable
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).

Some packages can't be installed according to Ubuntu. What can I do?

freeling-3.1-quantal-x86_64.deb is for ubuntu Quantal (12.10) and it expects to find library versions that come with that distribution.

Newer ubuntus do not have such old versions of the required libraries, so this package won't install.

We will release FreeLing 4.0 packages for newest ubuntus soon.

Meanwhile, you'll need to compile from source code.