Compiler Version Problem

Submitted by Macathy on Thu, 08/26/2021 - 00:07
Forums

Hello,

I am trying to install Freeling in a computer with Windows 10 (64 bits).
I already download all pre requisites and create de build folder.
But, when I execute “nmake install” command the installation was interrupted and print an error message as follow:“#error: STL1001: Unexpected compiler version, expected MSVC 19.15 or newer”.
I am using Visual Studio 2017 (Express Edition) with MSVC version 14.16.27023 and Freeling version 4.2.
Please could you tell What am I doing wrong?

Regards,
M.

MSVC is not able to link binaries created with different versions of the compiler (yes, I know, MS sucks, but it is up to you to move on)

If you build FreeLing with a version different than the one used to build the dependencies (boost, etc) you'll get an error.

In any case, the error you get may be caused by something else, but I can't tell without more context.  Please provide the last 10 or 15 lines output by cmake before the error.